After fresh installation of laravel 7 project,
C:\xampp\htdocs\blog>composer require jenssegers/mongodb --ignore-platform-reqs
But this is giving an error.
Your requirements could not be resolved to an installable set of packages.
Problem 1 - jenssegers/mongodb[v3.8.0, ..., v3.8.2] require illuminate/support ^8.0 -> found illuminate/support[v8.0.0, ..., 8.x-dev] but these were not loaded, likely because it conflicts with another require. - Root composer.json requires jenssegers/mongodb ^3.8 -> satisfiable by jenssegers/mongodb[v3.8.0, v3.8.1, v3.8.2].
Also unintalled old composer and installed latest version of it. But still the same issue
Got the issue: Need to check the laravel version compatibility with jenssegers/Laravel-MongoDB. You can check it here:
Laravel version Compatibility Laravel Package 4.2.x 2.0.x 5.0.x 2.1.x 5.1.x 2.2.x or 3.0.x 5.2.x 2.3.x or 3.0.x 5.3.x 3.1.x or 3.2.x 5.4.x 3.2.x 5.5.x 3.3.x 5.6.x 3.4.x 5.7.x 3.4.x 5.8.x 3.5.x 6.x 3.6.x 7.x 3.7.x 8.x 3.8.x
And in cmd i Did like this:
C:\xampp\htdocs\blog> composer require jenssegers/mongodb 3.7
Hope this helps anyone with the same issue
In Laravel 8 it worked like this:
composer require jenssegers/mongodb 3.8.x
the ".x" is important, otherwise it marks the same error in MacOs.